Letztes Jahr habe ich mir ein HP Notebook gegönnt. Ganz neu aus dem Laden. Wer mich kennt, weiß das ich eigentlich nicht gerne Geld für Hardware ausgebe. Gerne gebrauchte und alte Dinge. Aber 2018 war ein sehr beschissenes Jahr und so wollte ich mich 2019 belohnen.

Wenn ich mich so im Internet umschaue, war ich auch mit meiner Neuanschaffung mehr als Sparsam. So bin ich halt. Irgendwas um die 500€ hat mein kleines Schwarzes mich gekostet.

Das Windows 10 wurde sofort durch ein Linux ersetzt. Und damit ging der Ärger auch schon los. Denn der eingebaute WLAN Adapter wollte nicht gefunden werden. Ich hab dann der Suchmaschine meiner Wahl eine Lösung die notwendigen Schritte für Linux Mint gefunden und die Treiber installiert. Es gab dann aber weiterhin doch Probleme. Das Notebook hatte immer eine verdammt schlechte Verbindung, die auch oft weggefallen ist. Jetzt könnte man es natürlich auf das WLAN selber schieben. Aber z.B. das Smartphone das direkt neben dran liegt hat all diese Probleme nicht. Auch mit dem vorherigen Thinkpad oder Acer Laptop hatte ich all diese Probleme nicht gehabt.

Ich besorgte mir dann einen WLAN Stick, der sofort erkannt wurde und auch grundsätzlich lief. In meiner Einbildung war jetzt alles super. Nur das ich eben einen USB-Port mit dem Dongel fürs Internet belegte. Kann man ja mit um. Kein Ding.

Im Laufe der Zeit stellte sich aber heraus das es mit dem WLAN Stick zwar besser, aber weit weg von Perfekt gewesen ist. Ich kann das Problem bis heute nicht lösen.

Mittlerweile gab es aber diverse Kernelupdates und so hoffe ich, das es sich inzwischen gebessert hat, wenn ich die Originaltreiber wieder installiert habe. Nur weiß ich nicht mehr. Also schnell wieder gesucht …. und nach viel zu langer Zeit wieder gefunden. Damit es nächste mal einfacher ist, steht es jetzt hier….

Mit

lspci -nnk | grep -i net -A2

findet man heraus welche Karte installiert ist. In meinem Fall

	
	
	

	
03:00.0 Ethernet controller [0200] : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] 
	 (rev 15)
	Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:84a2] 
	
	

	Kernel driver in use: r8169
	Kernel modules: r8169
04:00.0 Network controller [0280] : Realtek Semiconductor Co., Ltd. Device [10ec:d723] 
	
	Subsystem: Hewlett-Packard Company Device [103c:8319] 

05:00.0 VGA compatible controller [0300] : Advanced Micro Devices, Inc. [AMD/ATI]  Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] [1002:15dd]  (rev c4)

Und deswegen muss ich folgende Befehle durchführen:




sudo apt-get install dkms git build-essential
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo cp -r rtlwifi_new/firmware/rtlwifi/ /lib/firmware/

Na und jetzt mal schauen, ob nach dem Reboot alles ein wenig besser ist ….